Apache ActiveMQ Deserialization of Untrusted Data Vulnerability
The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by…
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 5 / 5
- KEV catalog (CISA)02 Nov 2023
- Exploited in EUVD (ENISA)02 Nov 2023
- Used by ransomwareyes
- EPSS above 10 %99.99%
- No account, over the networkyes
What to do
Fix
Apply the vendor’s fix as soon as it is available.
CISA guidance: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Description ENISA EUVD
The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.
Affected products
- 5.16.0 <5.16.7
- 5.8.0 <5.15.16
- 5.18.0 <5.18.3
- 5.17.0 <5.17.6
- 0 <5.15.16
Open source packages OSV
Affected libraries according to OSV, with fixed versions.
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 99.99%
References
Other exploited vulnerabilities from the same vendor
- CVE-2016-3081Apache Struts Command Injection Vulnerability8.5 · Rising fast
- CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability8.4 · Actively exploited
- CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability8.3 · Background exploitation
- CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability9.0 · Background exploitation
- CVE-2025-24813Apache Tomcat Path Equivalence Vulnerability9.4 · Background exploitation
- CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability9.3 · Background exploitation