Apache ActiveMQ Deserialization of Untrusted Data Vulnerability
The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by…
Gravité = CVSS. Probabilité = EPSS (FIRST). Exploitation = signaux publics : KEV, EUVD, rançongiciel, EPSS au-dessus de 10 %, accès sans compte.
Probabilité d’exploitation EPSS · FIRST
Signaux d’exploitation 5 / 5
- Catalogue KEV (CISA)02/11/2023
- EUVD exploitée (ENISA)02/11/2023
- Utilisée par des rançongicielsoui
- EPSS au-dessus de 10 %99,99 %
- Sans compte, par le réseauoui
Que faire
Corriger
Appliquer le correctif de l’éditeur dès qu’il est disponible.
Consigne de la CISA : Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
En attendant
Retirer le service d’internet ou en filtrer l’accès, surveiller les journaux et chercher des traces de compromission.
Éditeurs (CRA)
Faille exploitée dans votre produit : alerte précoce à l’ENISA sous 24 h, puis notification sous 72 h (article 14 du Cyber Resilience Act). Le CRA expliqué
Description ENISA EUVD
The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.
Texte de la source, en anglais.
Produits touchés
- 5.16.0 <5.16.7
- 5.8.0 <5.15.16
- 5.18.0 <5.18.3
- 5.17.0 <5.17.6
- 0 <5.15.16
Paquets open source OSV
Bibliothèques touchées selon OSV, avec les versions corrigées.
Chronologie
-
Publication
-
Exploitation signalée (ENISA)
-
Ajout au catalogue KEV
-
Échéance de correction CISA
-
EPSS au plus haut : 99,99 %
Références
Autres failles exploitées du même éditeur
- CVE-2016-3081Apache Struts Command Injection Vulnerability8,5 · Montée rapide
- CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability8,4 · Exploitation active
- CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability8,3 · Exploitation de fond
- CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability9,0 · Exploitation de fond
- CVE-2025-24813Apache Tomcat Path Equivalence Vulnerability9,4 · Exploitation de fond
- CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability9,3 · Exploitation de fond