Apache ActiveMQ Deserialization of Untrusted Data Vulnerability
The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by…
Schweregrad = CVSS. Wahrscheinlichkeit = EPSS (FIRST). Ausnutzung = öffentliche Signale: KEV, EUVD, Ransomware, EPSS über 10 %, ohne Konto.
Ausnutzungswahrscheinlichkeit EPSS · FIRST
Ausnutzungssignale 5 / 5
- KEV-Katalog (CISA)02.11.2023
- In der EUVD ausgenutzt (ENISA)02.11.2023
- Von Ransomware genutztja
- EPSS über 10 %99,99 %
- Ohne Konto, über das Netzja
Was tun
Beheben
Den Patch des Herstellers einspielen, sobald er verfügbar ist.
Vorgabe der CISA: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Bis dahin
Den Dienst vom Internet nehmen oder den Zugriff einschränken, Protokolle überwachen und nach Kompromittierungsspuren suchen.
Hersteller (CRA)
Ausgenutzte Schwachstelle in Ihrem Produkt: Frühwarnung an die ENISA binnen 24 h, dann Meldung binnen 72 h (Artikel 14 des Cyber Resilience Act). Der CRA erklärt
Beschreibung ENISA EUVD
The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.
Text der Quelle, auf Englisch.
Betroffene Produkte
- 5.16.0 <5.16.7
- 5.8.0 <5.15.16
- 5.18.0 <5.18.3
- 5.17.0 <5.17.6
- 0 <5.15.16
Open-Source-Pakete OSV
Betroffene Bibliotheken laut OSV, mit behobenen Versionen.
Zeitverlauf
-
Veröffentlichung
-
Ausnutzung gemeldet (ENISA)
-
Aufnahme in den KEV-Katalog
-
CISA-Frist zur Behebung
-
EPSS-Höchstwert: 99,99 %
Referenzen
Weitere ausgenutzte Schwachstellen desselben Herstellers
- CVE-2016-3081Apache Struts Command Injection Vulnerability8,5 · Stark steigend
- CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability8,4 · Aktiv ausgenutzt
- CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability8,3 · Dauerhaft ausgenutzt
- CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability9,0 · Dauerhaft ausgenutzt
- CVE-2025-24813Apache Tomcat Path Equivalence Vulnerability9,4 · Dauerhaft ausgenutzt
- CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability9,3 · Dauerhaft ausgenutzt