Apache Tomcat Path Equivalence Vulnerability
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache…
Gravité = CVSS. Probabilité = EPSS (FIRST). Exploitation = signaux publics : KEV, EUVD, rançongiciel, EPSS au-dessus de 10 %, accès sans compte.
Probabilité d’exploitation EPSS · FIRST
Signaux d’exploitation 4 / 5
- Catalogue KEV (CISA)01/04/2025
- EUVD exploitée (ENISA)01/04/2025
- Utilisée par des rançongicielsnon
- EPSS au-dessus de 10 %99,9 %
- Sans compte, par le réseauoui
Que faire
Corriger
Appliquer le correctif de l’éditeur dès qu’il est disponible.
Consigne de la CISA : Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
En attendant
Retirer le service d’internet ou en filtrer l’accès, surveiller les journaux et chercher des traces de compromission.
Éditeurs (CRA)
Faille exploitée dans votre produit : alerte précoce à l’ENISA sous 24 h, puis notification sous 72 h (article 14 du Cyber Resilience Act). Le CRA expliqué
Description ENISA EUVD
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.
Texte de la source, en anglais.
Produits touchés
- 8.5.0 ≤8.5.100
- 9.0.0.M1 ≤9.0.98
- 11.0.0-M1 ≤11.0.2
- 10.1.0-M1 ≤10.1.34
Paquets open source OSV
Bibliothèques touchées selon OSV, avec les versions corrigées.
Chronologie
-
Publication
-
Exploitation signalée (ENISA)
-
Ajout au catalogue KEV
-
Échéance de correction CISA
-
EPSS au plus haut : 99,9 %
Références
Autres failles exploitées du même éditeur
- CVE-2016-3081Apache Struts Command Injection Vulnerability8,5 · Montée rapide
- CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability8,4 · Exploitation active
- CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability8,3 · Exploitation de fond
- CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability9,0 · Exploitation de fond
- CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability9,3 · Exploitation de fond
- CVE-2024-27348Apache HugeGraph-Server Improper Access Control Vulnerability9,3 · Exploitation de fond