Background exploitation KEV catalog No authentication
CVE-2025-24813

Apache Tomcat Path Equivalence Vulnerability

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache…

CheckOps priority index
9.4/10 Patch within 24 h
Severity10.0
Probability10.0
Exploitation4/5

Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.

EPSS · today 99.9% higher than 99.97% of CVEs
CVSS 3.1 10.0 AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:
Exploited for 581 days 01 Apr 2025
CISA due date 22 Apr 2025 for US federal agencies

Exploitation probability EPSS · FIRST

05010025 Sep05 Oct15 Oct24 Oct02 Nov
EPSS probability (%)Percentile among all CVEs

Exploitation signals 4 / 5

  • KEV catalog (CISA)01 Apr 2025
  • Exploited in EUVD (ENISA)01 Apr 2025
  • Used by ransomwareno
  • EPSS above 10 %99.9%
  • No account, over the networkyes

What to do

Fix

Apply the vendor’s fix as soon as it is available.

CISA guidance: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Meanwhile

Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.

Manufacturers (CRA)

Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained

Description ENISA EUVD

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

Affected products

Apache TomcatTomcat
Affected versions
  • 8.5.0 ≤8.5.100
  • 9.0.0.M1 ≤9.0.98
  • 11.0.0-M1 ≤11.0.2
  • 10.1.0-M1 ≤10.1.34
Weaknesses (CWE)

Open source packages OSV

Affected libraries according to OSV, with fixed versions.

Timeline

  1. Published

  2. Exploitation reported (ENISA)

  3. Added to the KEV catalog

  4. CISA remediation due date

  5. EPSS peak: 99.9%

References

Other exploited vulnerabilities from the same vendor

  • CVE-2016-3081Apache Struts Command Injection Vulnerability
    8.5 · Rising fast
  • CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability
    8.4 · Actively exploited
  • CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability
    8.3 · Background exploitation
  • CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability
    9.0 · Background exploitation
  • CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability
    9.3 · Background exploitation
  • CVE-2024-27348Apache HugeGraph-Server Improper Access Control Vulnerability
    9.3 · Background exploitation

Are you affected?

CheckOps reads your SBOMs and scans, and alerts you as soon as one of your dependencies is exploited.

Get notified at launch

Sources: CISA KEV · ENISA EUVD · FIRST EPSS · OSV. Public data aggregated by CheckOps, updated automatically. Source texts remain the property of their authors. All exploited vulnerabilities