Actively exploited KEV catalog No authentication
CVE-2026-34486

Apache Tomcat Missing Encryption of Sensitive Data Vulnerability

Missing Encryption of Sensitive Data vulnerability in Apache Tomcat due to the fix for CVE-2026-29146 allowing the bypass of the EncryptInterceptor. This issue affects Apache Tomcat: 11.0.20, 10.1.53, 9.0.116. Users are recommended to…

CheckOps priority index
8.4/10 Patch within 24 h
Severity7.5
Probability9.9
Exploitation4/5

Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.

EPSS · today 98.5% higher than 99.9% of CVEs
CVSS 3.1 7.5 AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:
Exploited for 91 days 04 Aug 2026
CISA due date 07 Aug 2026 for US federal agencies

Exploitation probability EPSS · FIRST

05010025 Sep05 Oct15 Oct24 Oct02 Nov
EPSS probability (%)Percentile among all CVEs

Exploitation signals 4 / 5

  • KEV catalog (CISA)04 Aug 2026
  • Exploited in EUVD (ENISA)04 Aug 2026
  • Used by ransomwareno
  • EPSS above 10 %98.5%
  • No account, over the networkyes

What to do

Fix

Apply the vendor’s fix as soon as it is available.

CISA guidance: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

Meanwhile

Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.

Manufacturers (CRA)

Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained

Description ENISA EUVD

Missing Encryption of Sensitive Data vulnerability in Apache Tomcat due to the fix for CVE-2026-29146 allowing the bypass of the EncryptInterceptor. This issue affects Apache Tomcat: 11.0.20, 10.1.53, 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.

Affected products

Apache TomcatTomcat
Affected versions
  • 11.0.20
  • 9.0.116
  • 10.1.53
Weaknesses (CWE)

Open source packages OSV

Affected libraries according to OSV, with fixed versions.

Timeline

  1. Published

  2. Exploitation reported (ENISA)

  3. Added to the KEV catalog

  4. CISA remediation due date

  5. EPSS peak: 98.5%

References

Other exploited vulnerabilities from the same vendor

  • CVE-2016-3081Apache Struts Command Injection Vulnerability
    8.5 · Rising fast
  • CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability
    8.3 · Background exploitation
  • CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability
    9.0 · Background exploitation
  • CVE-2025-24813Apache Tomcat Path Equivalence Vulnerability
    9.4 · Background exploitation
  • CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability
    9.3 · Background exploitation
  • CVE-2024-27348Apache HugeGraph-Server Improper Access Control Vulnerability
    9.3 · Background exploitation

Are you affected?

CheckOps reads your SBOMs and scans, and alerts you as soon as one of your dependencies is exploited.

Get notified at launch

Sources: CISA KEV · ENISA EUVD · FIRST EPSS · OSV. Public data aggregated by CheckOps, updated automatically. Source texts remain the property of their authors. All exploited vulnerabilities