Apache RocketMQ Command Execution Vulnerability
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission…
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 4 / 5
- KEV catalog (CISA)06 Sept 2023
- Exploited in EUVD (ENISA)06 Sept 2023
- Used by ransomwareno
- EPSS above 10 %96.6%
- No account, over the networkyes
What to do
Fix
Apply the vendor’s fix as soon as it is available.
CISA guidance: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Description ENISA EUVD
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
Affected products
- 0 ≤5.1.0
Open source packages OSV
Affected libraries according to OSV, with fixed versions.
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 96.6%
References
Other exploited vulnerabilities from the same vendor
- CVE-2016-3081Apache Struts Command Injection Vulnerability8.5 · Rising fast
- CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability8.4 · Actively exploited
- CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability8.3 · Background exploitation
- CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability9.0 · Background exploitation
- CVE-2025-24813Apache Tomcat Path Equivalence Vulnerability9.4 · Background exploitation
- CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability9.3 · Background exploitation