Apache RocketMQ Command Execution Vulnerability
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission…
Schweregrad = CVSS. Wahrscheinlichkeit = EPSS (FIRST). Ausnutzung = öffentliche Signale: KEV, EUVD, Ransomware, EPSS über 10 %, ohne Konto.
Ausnutzungswahrscheinlichkeit EPSS · FIRST
Ausnutzungssignale 4 / 5
- KEV-Katalog (CISA)06.09.2023
- In der EUVD ausgenutzt (ENISA)06.09.2023
- Von Ransomware genutztnein
- EPSS über 10 %96,6 %
- Ohne Konto, über das Netzja
Was tun
Beheben
Den Patch des Herstellers einspielen, sobald er verfügbar ist.
Vorgabe der CISA: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Bis dahin
Den Dienst vom Internet nehmen oder den Zugriff einschränken, Protokolle überwachen und nach Kompromittierungsspuren suchen.
Hersteller (CRA)
Ausgenutzte Schwachstelle in Ihrem Produkt: Frühwarnung an die ENISA binnen 24 h, dann Meldung binnen 72 h (Artikel 14 des Cyber Resilience Act). Der CRA erklärt
Beschreibung ENISA EUVD
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
Text der Quelle, auf Englisch.
Betroffene Produkte
- 0 ≤5.1.0
Open-Source-Pakete OSV
Betroffene Bibliotheken laut OSV, mit behobenen Versionen.
Zeitverlauf
-
Veröffentlichung
-
Ausnutzung gemeldet (ENISA)
-
Aufnahme in den KEV-Katalog
-
CISA-Frist zur Behebung
-
EPSS-Höchstwert: 96,6 %
Referenzen
Weitere ausgenutzte Schwachstellen desselben Herstellers
- CVE-2016-3081Apache Struts Command Injection Vulnerability8,5 · Stark steigend
- CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability8,4 · Aktiv ausgenutzt
- CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability8,3 · Dauerhaft ausgenutzt
- CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability9,0 · Dauerhaft ausgenutzt
- CVE-2025-24813Apache Tomcat Path Equivalence Vulnerability9,4 · Dauerhaft ausgenutzt
- CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability9,3 · Dauerhaft ausgenutzt