Apache RocketMQ Command Execution Vulnerability
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission…
Gravité = CVSS. Probabilité = EPSS (FIRST). Exploitation = signaux publics : KEV, EUVD, rançongiciel, EPSS au-dessus de 10 %, accès sans compte.
Probabilité d’exploitation EPSS · FIRST
Signaux d’exploitation 4 / 5
- Catalogue KEV (CISA)06/09/2023
- EUVD exploitée (ENISA)06/09/2023
- Utilisée par des rançongicielsnon
- EPSS au-dessus de 10 %96,6 %
- Sans compte, par le réseauoui
Que faire
Corriger
Appliquer le correctif de l’éditeur dès qu’il est disponible.
Consigne de la CISA : Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
En attendant
Retirer le service d’internet ou en filtrer l’accès, surveiller les journaux et chercher des traces de compromission.
Éditeurs (CRA)
Faille exploitée dans votre produit : alerte précoce à l’ENISA sous 24 h, puis notification sous 72 h (article 14 du Cyber Resilience Act). Le CRA expliqué
Description ENISA EUVD
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
Texte de la source, en anglais.
Produits touchés
- 0 ≤5.1.0
Paquets open source OSV
Bibliothèques touchées selon OSV, avec les versions corrigées.
Chronologie
-
Publication
-
Exploitation signalée (ENISA)
-
Ajout au catalogue KEV
-
Échéance de correction CISA
-
EPSS au plus haut : 96,6 %
Références
Autres failles exploitées du même éditeur
- CVE-2016-3081Apache Struts Command Injection Vulnerability8,5 · Montée rapide
- CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability8,4 · Exploitation active
- CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability8,3 · Exploitation de fond
- CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability9,0 · Exploitation de fond
- CVE-2025-24813Apache Tomcat Path Equivalence Vulnerability9,4 · Exploitation de fond
- CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability9,3 · Exploitation de fond