Apache Log4j2 Remote Code Execution Vulnerability
Apache Log4j2 2.0-beta9 through 2.15.0 (excluding security releases 2.12.2, 2.12.3, and 2.3.1) JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related…
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 5 / 5
- KEV catalog (CISA)10 Dec 2021
- Exploited in EUVD (ENISA)10 Dec 2021
- Used by ransomwareyes
- EPSS above 10 %100.00%
- No account, over the networkyes
What to do
Fix
Update to a fixed version: 2.15.0 2.3.1 2.12.2
CISA guidance: For all affected software assets for which updates exist, the only acceptable remediation actions are: 1) Apply updates; OR 2) remove affected assets from agency networks. Temporary mitigations using one of the measures provided at https://www.cisa.gov/uscert/ed-22-02-apache-log4j-recommended-mitigation-measures are only acceptable until updates are available.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Description ENISA EUVD
Apache Log4j2 2.0-beta9 through 2.15.0 (excluding security releases 2.12.2, 2.12.3, and 2.3.1) JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled. From log4j 2.15.0, this behavior has been disabled by default. From version 2.16.0 (along with 2.12.2, 2.12.3, and 2.3.1), this functionality has been completely removed. Note that this vulnerability is specific to log4j-core and does not affect log4net, log4cxx, or other Apache Logging Services projects.
Affected products
- 2.0-beta9 <log4j-core*
Open source packages OSV
- org.apache.logging.log4j:log4j-coreMaven · GHSA-jfh8-c2jp-5v3qfixed in 2.15.0
- org.apache.logging.log4j:log4j-coreMaven · GHSA-jfh8-c2jp-5v3qfixed in 2.3.1
- org.apache.logging.log4j:log4j-coreMaven · GHSA-jfh8-c2jp-5v3qfixed in 2.12.2
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 100.00%
References
- cve.org · CVE-2021-44228
- ENISA EUVD · EUVD-2021-34768
- CISA KEV
- FIRST EPSS
- logging.apache.org
- openwall.com
- openwall.com
- tools.cisco.com
- openwall.com
- security.netapp.com
- packetstormsecurity.com
- psirt.global.sonicwall.com
- oracle.com
- debian.org
- lists.debian.org
- lists.fedoraproject.org
- msrc-blog.microsoft.com
- openwall.com
- openwall.com
- openwall.com
Other exploited vulnerabilities from the same vendor
- CVE-2016-3081Apache Struts Command Injection Vulnerability8.5 · Rising fast
- CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability8.4 · Actively exploited
- CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability8.3 · Background exploitation
- CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability9.0 · Background exploitation
- CVE-2025-24813Apache Tomcat Path Equivalence Vulnerability9.4 · Background exploitation
- CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability9.3 · Background exploitation