Background exploitation KEV catalog Ransomware No authentication
CVE-2021-42013

Apache HTTP Server Path Traversal Vulnerability

It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of…

CheckOps priority index
9.9/10 Patch within 24 h
Severity9.8
Probability10.0
Exploitation5/5

Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.

EPSS · today 99.96% higher than 99.98% of CVEs
CVSS 3.1 9.8 AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:
Exploited for 1,826 days 03 Nov 2021
CISA due date 17 Nov 2021 for US federal agencies

Exploitation probability EPSS · FIRST

05010026 Sep05 Oct15 Oct24 Oct02 Nov
EPSS probability (%)Percentile among all CVEs

Exploitation signals 5 / 5

  • KEV catalog (CISA)03 Nov 2021
  • Exploited in EUVD (ENISA)03 Nov 2021
  • Used by ransomwareyes
  • EPSS above 10 %99.96%
  • No account, over the networkyes

What to do

Fix

Update to a fixed version: 2.4.51-1

CISA guidance: Apply updates per vendor instructions.

Meanwhile

Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.

Manufacturers (CRA)

Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained

Description ENISA EUVD

It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.

Affected products

Apache HTTP ServerHTTP Server
Affected versions
  • Apache HTTP Server 2.4.50
  • Apache HTTP Server 2.4.49
Weaknesses (CWE)

Open source packages OSV

  • apache2Debian:13 · CVE-2021-42013
    fixed in 2.4.51-1

Timeline

  1. Published

  2. Exploitation reported (ENISA)

  3. Added to the KEV catalog

  4. CISA remediation due date

  5. EPSS peak: 99.96%

References

Other exploited vulnerabilities from the same vendor

  • CVE-2016-3081Apache Struts Command Injection Vulnerability
    8.5 · Rising fast
  • CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability
    8.4 · Actively exploited
  • CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability
    8.3 · Background exploitation
  • CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability
    9.0 · Background exploitation
  • CVE-2025-24813Apache Tomcat Path Equivalence Vulnerability
    9.4 · Background exploitation
  • CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability
    9.3 · Background exploitation

Are you affected?

CheckOps reads your SBOMs and scans, and alerts you as soon as one of your dependencies is exploited.

Get notified at launch

Sources: CISA KEV · ENISA EUVD · FIRST EPSS · OSV. Public data aggregated by CheckOps, updated automatically. Source texts remain the property of their authors. All exploited vulnerabilities