Background exploitation KEV catalog Ransomware No authentication
CVE-2021-40438

Apache HTTP Server-Side Request Forgery (SSRF)

A crafted request uri-path can cause mod_proxy to forward the request to an origin server choosen by the remote user. This issue affects Apache HTTP Server 2.4.48 and earlier.

CheckOps priority index
9.6/10 Patch within 24 h
Severity9.0
Probability10.0
Exploitation5/5

Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.

EPSS · today 100.00% higher than 100.00% of CVEs
CVSS 3.1 9.0 AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:
Exploited for 1,798 days 01 Dec 2021
CISA due date 15 Dec 2021 for US federal agencies

Exploitation probability EPSS · FIRST

05010026 Sep05 Oct15 Oct24 Oct02 Nov
EPSS probability (%)Percentile among all CVEs

Exploitation signals 5 / 5

  • KEV catalog (CISA)01 Dec 2021
  • Exploited in EUVD (ENISA)01 Dec 2021
  • Used by ransomwareyes
  • EPSS above 10 %100.00%
  • No account, over the networkyes

What to do

Fix

Update to a fixed version: 2.4.49-1

CISA guidance: Apply updates per vendor instructions.

Meanwhile

Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.

Manufacturers (CRA)

Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained

Affected products

Apache HTTP ServerApache
Affected versions
  • Apache HTTP Server 2.4 ≤2.4.48
Weaknesses (CWE)

Open source packages OSV

  • apache2Debian:13 · CVE-2021-40438
    fixed in 2.4.49-1

Timeline

  1. Published

  2. Exploitation reported (ENISA)

  3. Added to the KEV catalog

  4. CISA remediation due date

  5. EPSS peak: 100.00%

References

Other exploited vulnerabilities from the same vendor

  • CVE-2016-3081Apache Struts Command Injection Vulnerability
    8.5 · Rising fast
  • CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability
    8.4 · Actively exploited
  • CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability
    8.3 · Background exploitation
  • CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability
    9.0 · Background exploitation
  • CVE-2025-24813Apache Tomcat Path Equivalence Vulnerability
    9.4 · Background exploitation
  • CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability
    9.3 · Background exploitation

Are you affected?

CheckOps reads your SBOMs and scans, and alerts you as soon as one of your dependencies is exploited.

Get notified at launch

Sources: CISA KEV · ENISA EUVD · FIRST EPSS · OSV. Public data aggregated by CheckOps, updated automatically. Source texts remain the property of their authors. All exploited vulnerabilities