Background exploitation KEV catalog
CVE-2019-0211

Apache HTTP Server Privilege Escalation Vulnerability

In Apache HTTP Server 2.4 releases 2.4.17 to 2.4.38, with MPM event, worker or prefork, code executing in less-privileged child processes or threads (including scripts executed by an in-process scripting interpreter) could execute…

CheckOps priority index
6.9/10 Patch within 7 days
Severity7.8
Probability6.5
Exploitation3/5

Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.

EPSS · today 65.0% higher than 99.3% of CVEs
CVSS 3.1 7.8 AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:
Exploited for 1,826 days 03 Nov 2021
CISA due date 03 May 2022 for US federal agencies

Exploitation probability EPSS · FIRST

05010026 Sep05 Oct15 Oct24 Oct02 Nov
EPSS probability (%)Percentile among all CVEs

Exploitation signals 3 / 5

  • KEV catalog (CISA)03 Nov 2021
  • Exploited in EUVD (ENISA)03 Nov 2021
  • Used by ransomwareno
  • EPSS above 10 %65.0%
  • No account, over the networkno

What to do

Fix

Update to a fixed version: 2.4.38-3

CISA guidance: Apply updates per vendor instructions.

Meanwhile

Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.

Manufacturers (CRA)

Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained

Description ENISA EUVD

In Apache HTTP Server 2.4 releases 2.4.17 to 2.4.38, with MPM event, worker or prefork, code executing in less-privileged child processes or threads (including scripts executed by an in-process scripting interpreter) could execute arbitrary code with the privileges of the parent process (usually root) by manipulating the scoreboard. Non-Unix systems are not affected.

Affected products

Apache HTTP ServerHTTP Server
Affected versions
  • 2.4.17 to 2.4.38
Weaknesses (CWE)

Open source packages OSV

  • apache2Debian:13 · CVE-2019-0211
    fixed in 2.4.38-3

Timeline

  1. Published

  2. Exploitation reported (ENISA)

  3. Added to the KEV catalog

  4. CISA remediation due date

  5. EPSS peak: 65.0%

References

Other exploited vulnerabilities from the same vendor

  • CVE-2016-3081Apache Struts Command Injection Vulnerability
    8.5 · Rising fast
  • CVE-2026-34486Apache Tomcat Missing Encryption of Sensitive Data Vulnerability
    8.4 · Actively exploited
  • CVE-2026-34197Apache ActiveMQ Improper Input Validation Vulnerability
    8.3 · Background exploitation
  • CVE-2024-38475Apache HTTP Server Improper Escaping of Output Vulnerability
    9.0 · Background exploitation
  • CVE-2025-24813Apache Tomcat Path Equivalence Vulnerability
    9.4 · Background exploitation
  • CVE-2024-45195Apache OFBiz Forced Browsing Vulnerability
    9.3 · Background exploitation

Are you affected?

CheckOps reads your SBOMs and scans, and alerts you as soon as one of your dependencies is exploited.

Get notified at launch

Sources: CISA KEV · ENISA EUVD · FIRST EPSS · OSV. Public data aggregated by CheckOps, updated automatically. Source texts remain the property of their authors. All exploited vulnerabilities