Ignite Realtime Openfire Path Traversal Vulnerability
Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an…
Gravité = CVSS. Probabilité = EPSS (FIRST). Exploitation = signaux publics : KEV, EUVD, rançongiciel, EPSS au-dessus de 10 %, accès sans compte.
Probabilité d’exploitation EPSS · FIRST
Signaux d’exploitation 4 / 5
- Catalogue KEV (CISA)24/08/2023
- EUVD exploitée (ENISA)24/08/2023
- Utilisée par des rançongicielsnon
- EPSS au-dessus de 10 %100,00 %
- Sans compte, par le réseauoui
Que faire
Corriger
Appliquer le correctif de l’éditeur dès qu’il est disponible.
Consigne de la CISA : Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
En attendant
Retirer le service d’internet ou en filtrer l’accès, surveiller les journaux et chercher des traces de compromission.
Éditeurs (CRA)
Faille exploitée dans votre produit : alerte précoce à l’ENISA sous 24 h, puis notification sous 72 h (article 14 du Cyber Resilience Act). Le CRA expliqué
Description ENISA EUVD
Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.
Texte de la source, en anglais.
Produits touchés
- 3.10.0, < 4.6.8
- 4.7.0, < 4.7.5
Paquets open source OSV
Bibliothèques touchées selon OSV, avec les versions corrigées.
Chronologie
-
Publication
-
Exploitation signalée (ENISA)
-
Ajout au catalogue KEV
-
Échéance de correction CISA
-
EPSS au plus haut : 100,00 %