Dauerhaft ausgenutzt KEV-Katalog Ohne Anmeldung
CVE-2023-32315

Ignite Realtime Openfire Path Traversal Vulnerability

Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an…

CheckOps-Prioritätsindex
8,8/10 Binnen 24 h patchen
Schweregrad8,6
Wahrscheinlichkeit10,0
Ausnutzung4/5

Schweregrad = CVSS. Wahrscheinlichkeit = EPSS (FIRST). Ausnutzung = öffentliche Signale: KEV, EUVD, Ransomware, EPSS über 10 %, ohne Konto.

EPSS · heute 100,00 % höher als 99,99 % aller CVE
CVSS 3.1 8,6 AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:
Ausgenutzt seit 1.167 Tagen 24.08.2023
CISA-Frist 14.09.2023 für US-Bundesbehörden

Ausnutzungswahrscheinlichkeit EPSS · FIRST

05010026.0905.1015.1024.1002.11
EPSS-Wahrscheinlichkeit (%)Perzentil unter allen CVE

Ausnutzungssignale 4 / 5

  • KEV-Katalog (CISA)24.08.2023
  • In der EUVD ausgenutzt (ENISA)24.08.2023
  • Von Ransomware genutztnein
  • EPSS über 10 %100,00 %
  • Ohne Konto, über das Netzja

Was tun

Beheben

Den Patch des Herstellers einspielen, sobald er verfügbar ist.

Vorgabe der CISA: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Bis dahin

Den Dienst vom Internet nehmen oder den Zugriff einschränken, Protokolle überwachen und nach Kompromittierungsspuren suchen.

Hersteller (CRA)

Ausgenutzte Schwachstelle in Ihrem Produkt: Frühwarnung an die ENISA binnen 24 h, dann Meldung binnen 72 h (Artikel 14 des Cyber Resilience Act). Der CRA erklärt

Beschreibung ENISA EUVD

Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.

Text der Quelle, auf Englisch.

Betroffene Produkte

Openfire
Betroffene Versionen
  • 3.10.0, < 4.6.8
  • 4.7.0, < 4.7.5
Schwächen (CWE)

Open-Source-Pakete OSV

Betroffene Bibliotheken laut OSV, mit behobenen Versionen.

Zeitverlauf

  1. Veröffentlichung

  2. Ausnutzung gemeldet (ENISA)

  3. Aufnahme in den KEV-Katalog

  4. CISA-Frist zur Behebung

  5. EPSS-Höchstwert: 100,00 %

Referenzen

Sind Sie betroffen?

CheckOps liest Ihre SBOMs und Scans und warnt Sie, sobald eine Ihrer Abhängigkeiten ausgenutzt wird.

Zum Start benachrichtigt werden

Quellen: CISA KEV · ENISA EUVD · FIRST EPSS · OSV. Öffentliche Daten, von CheckOps zusammengeführt und automatisch aktualisiert. Die Texte der Quellen bleiben Eigentum ihrer Autoren. Alle ausgenutzten Schwachstellen