n8n Improper Control of Dynamically-Managed Code Resources Vulnerability
n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system.…
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 3 / 5
- KEV catalog (CISA)11 Mar 2026
- Exploited in EUVD (ENISA)11 Mar 2026
- Used by ransomwareno
- EPSS above 10 %99.0%
- No account, over the networkno
What to do
Fix
Apply the vendor’s fix as soon as it is available.
CISA guidance: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Description ENISA EUVD
n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. This issue has been fixed in versions 1.120.4, 1.121.1, and 1.122.0. Users are strongly advised to upgrade to a patched version, which introduces additional safeguards to restrict expression evaluation. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only; and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully eliminate the risk and should only be used as short-term measures.
Affected products
- 0.211.0, < 1.120.4
- = 1.121.0
Open source packages OSV
Affected libraries according to OSV, with fixed versions.
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 99.0%