n8n Improper Control of Dynamically-Managed Code Resources Vulnerability
n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system.…
Schweregrad = CVSS. Wahrscheinlichkeit = EPSS (FIRST). Ausnutzung = öffentliche Signale: KEV, EUVD, Ransomware, EPSS über 10 %, ohne Konto.
Ausnutzungswahrscheinlichkeit EPSS · FIRST
Ausnutzungssignale 3 / 5
- KEV-Katalog (CISA)11.03.2026
- In der EUVD ausgenutzt (ENISA)11.03.2026
- Von Ransomware genutztnein
- EPSS über 10 %99,0 %
- Ohne Konto, über das Netznein
Was tun
Beheben
Den Patch des Herstellers einspielen, sobald er verfügbar ist.
Vorgabe der CISA: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Bis dahin
Den Dienst vom Internet nehmen oder den Zugriff einschränken, Protokolle überwachen und nach Kompromittierungsspuren suchen.
Hersteller (CRA)
Ausgenutzte Schwachstelle in Ihrem Produkt: Frühwarnung an die ENISA binnen 24 h, dann Meldung binnen 72 h (Artikel 14 des Cyber Resilience Act). Der CRA erklärt
Beschreibung ENISA EUVD
n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. This issue has been fixed in versions 1.120.4, 1.121.1, and 1.122.0. Users are strongly advised to upgrade to a patched version, which introduces additional safeguards to restrict expression evaluation. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only; and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully eliminate the risk and should only be used as short-term measures.
Text der Quelle, auf Englisch.
Betroffene Produkte
- 0.211.0, < 1.120.4
- = 1.121.0
Open-Source-Pakete OSV
Betroffene Bibliotheken laut OSV, mit behobenen Versionen.
Zeitverlauf
-
Veröffentlichung
-
Ausnutzung gemeldet (ENISA)
-
Aufnahme in den KEV-Katalog
-
CISA-Frist zur Behebung
-
EPSS-Höchstwert: 99,0 %