Background exploitation KEV catalog
CVE-2021-3493

Linux Kernel Privilege Escalation Vulnerability

The overlayfs implementation in the linux kernel did not properly validate with respect to user namespaces the setting of file capabilities on files in an underlying file system. Due to the combination of unprivileged user namespaces along…

CheckOps priority index
6.8/10 Patch within 7 days
Severity8.8
Probability4.9
Exploitation3/5

Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.

EPSS · today 49.2% higher than 98.9% of CVEs
CVSS 3.1 8.8 AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:
Exploited for 1,475 days 20 Oct 2022
CISA due date 10 Nov 2022 for US federal agencies

Exploitation probability EPSS · FIRST

05010026 Sep05 Oct15 Oct24 Oct02 Nov
EPSS probability (%)Percentile among all CVEs

Exploitation signals 3 / 5

  • KEV catalog (CISA)20 Oct 2022
  • Exploited in EUVD (ENISA)20 Oct 2022
  • Used by ransomwareno
  • EPSS above 10 %49.2%
  • No account, over the networkno

What to do

Fix

Update to a fixed version: 5.10.38-1

CISA guidance: Apply updates per vendor instructions.

Meanwhile

Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.

Manufacturers (CRA)

Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained

Description ENISA EUVD

The overlayfs implementation in the linux kernel did not properly validate with respect to user namespaces the setting of file capabilities on files in an underlying file system. Due to the combination of unprivileged user namespaces along with a patch carried in the Ubuntu kernel to allow unprivileged overlay mounts, an attacker could use this to gain elevated privileges.

Affected products

Linux kernelKernel
Affected versions
  • 5.4 kernel <5.4.0-72.80
  • 4.4 kernel <4.4.0-209.241
  • 5.8 kernel <5.8.0-50.56
  • 4.15 kernel <4.15.0-142.146
Weaknesses (CWE)

Open source packages OSV

  • linuxDebian:12 · CVE-2021-3493
    fixed in 5.10.38-1
  • linuxDebian:13 · CVE-2021-3493
    fixed in 5.10.38-1

Timeline

  1. Published

  2. Exploitation reported (ENISA)

  3. Added to the KEV catalog

  4. CISA remediation due date

  5. EPSS peak: 49.2%

References

Other exploited vulnerabilities from the same vendor

  • CVE-2026-46300Linux Kernel Missing Initialization of a Variable Vulnerability
    5.4 · Rising fast
  • CVE-2026-53266Linux Kernel Out-of-Bounds Write Vulnerability
    4.7 · Actively exploited
  • CVE-2025-39964Linux Kernel Race Condition Vulnerability
    4.4 · Actively exploited
  • CVE-2025-39682Linux Kernel Improper Check for Unusual or Exceptional Conditions Vulnerability
    5.8 · Actively exploited
  • CVE-2026-53362Linux Kernel Unspecified Vulnerability
    4.3 · Actively exploited
  • CVE-2022-0995Linux Kernel Out-of-Bounds Write Vulnerability
    4.6 · Actively exploited

Are you affected?

CheckOps reads your SBOMs and scans, and alerts you as soon as one of your dependencies is exploited.

Get notified at launch

Sources: CISA KEV · ENISA EUVD · FIRST EPSS · OSV. Public data aggregated by CheckOps, updated automatically. Source texts remain the property of their authors. All exploited vulnerabilities