Background exploitation KEV catalog No authentication
CVE-2020-11023

JQuery Cross-Site Scripting (XSS) Vulnerability

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and…

CheckOps priority index
7.7/10 Patch within 7 days
Severity6.9
Probability8.5
Exploitation4/5

Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.

EPSS · today 84.9% higher than 99.7% of CVEs
CVSS 3.1 6.9 AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:
Exploited for 650 days 23 Jan 2025
CISA due date 13 Feb 2025 for US federal agencies

Exploitation probability EPSS · FIRST

05010026 Sep05 Oct15 Oct24 Oct02 Nov
EPSS probability (%)Percentile among all CVEs

Exploitation signals 4 / 5

  • KEV catalog (CISA)23 Jan 2025
  • Exploited in EUVD (ENISA)23 Jan 2025
  • Used by ransomwareno
  • EPSS above 10 %84.9%
  • No account, over the networkyes

What to do

Fix

Update to a fixed version: 4.4.0 3.5.0

CISA guidance: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Meanwhile

Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.

Manufacturers (CRA)

Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained

Description ENISA EUVD

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Affected products

jQueryJQuery
Affected versions
  • 1.0.3, < 3.5.0
Weaknesses (CWE)

Open source packages OSV

  • jquery-railsRubyGems · GHSA-jpcq-cgw6-v4j6
    fixed in 4.4.0
  • jquerynpm · GHSA-jpcq-cgw6-v4j6
    fixed in 3.5.0

Timeline

  1. Published

  2. Exploitation reported (ENISA)

  3. Added to the KEV catalog

  4. CISA remediation due date

  5. EPSS peak: 84.9%

References

Are you affected?

CheckOps reads your SBOMs and scans, and alerts you as soon as one of your dependencies is exploited.

Get notified at launch

Sources: CISA KEV · ENISA EUVD · FIRST EPSS · OSV. Public data aggregated by CheckOps, updated automatically. Source texts remain the property of their authors. All exploited vulnerabilities