ImageMagick Arbitrary File Deletion Vulnerability
The EPHEMERAL coder in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allows remote attackers to delete arbitrary files via a crafted image.
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 3 / 5
- KEV catalog (CISA)03 Nov 2021
- Exploited in EUVD (ENISA)03 Nov 2021
- Used by ransomwareno
- EPSS above 10 %75.3%
- No account, over the networkno
What to do
Fix
Update to a fixed version: 8:6.9.6.2+dfsg-2
CISA guidance: Apply updates per vendor instructions.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Affected products
Open source packages OSV
- imagemagickDebian:12 · CVE-2016-3715fixed in 8:6.9.6.2+dfsg-2
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 75.3%
References
- cve.org · CVE-2016-3715
- ENISA EUVD · EUVD-2016-4736
- CISA KEV
- FIRST EPSS
- git.imagemagick.org
- lists.opensuse.org
- oracle.com
- imagemagick.org
- lists.opensuse.org
- ubuntu.com
- lists.opensuse.org
- securityfocus.com
- exploit-db.com
- lists.opensuse.org
- oracle.com
- openwall.com
- debian.org
- security.gentoo.org
- lists.opensuse.org
- slackware.com
Other exploited vulnerabilities from the same vendor
- CVE-2016-3714ImageMagick Improper Input Validation Vulnerability8.1 · Background exploitation
- CVE-2016-3718ImageMagick Server-Side Request Forgery (SSRF) Vulnerability6.3 · Background exploitation