ImageMagick Improper Input Validation Vulnerability
The (1) EPHEMERAL, (2) HTTPS, (3) MVG, (4) MSL, (5) TEXT, (6) SHOW, (7) WIN, and (8) PLT coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allow remote attackers to execute arbitrary code via shell metacharacters in a crafted…
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 3 / 5
- KEV catalog (CISA)09 Sept 2024
- Exploited in EUVD (ENISA)09 Sept 2024
- Used by ransomwareno
- EPSS above 10 %97.5%
- No account, over the networkno
What to do
Fix
Update to a fixed version: 8:6.9.6.2+dfsg-2
CISA guidance: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Description ENISA EUVD
The (1) EPHEMERAL, (2) HTTPS, (3) MVG, (4) MSL, (5) TEXT, (6) SHOW, (7) WIN, and (8) PLT coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allow remote attackers to execute arbitrary code via shell metacharacters in a crafted image, aka "ImageTragick."
Affected products
Open source packages OSV
- imagemagickDebian:12 · CVE-2016-3714fixed in 8:6.9.6.2+dfsg-2
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 97.5%
References
- cve.org · CVE-2016-3714
- ENISA EUVD · EUVD-2016-4735
- CISA KEV
- FIRST EPSS
- access.redhat.com
- git.imagemagick.org
- lists.opensuse.org
- securitytracker.com
- imagetragick.com
- oracle.com
- imagemagick.org
- openwall.com
- lists.opensuse.org
- lists.opensuse.org
- ubuntu.com
- lists.opensuse.org
- securityfocus.com
- exploit-db.com
- lists.opensuse.org
- rapid7.com
Other exploited vulnerabilities from the same vendor
- CVE-2016-3718ImageMagick Server-Side Request Forgery (SSRF) Vulnerability6.3 · Background exploitation
- CVE-2016-3715ImageMagick Arbitrary File Deletion Vulnerability6.3 · Background exploitation