Linux Kernel Race Condition Vulnerability
The n_tty_write function in drivers/tty/n_tty.c in the Linux kernel through 3.14.3 does not properly manage tty driver access in the "LECHO & !OPOST" case, which allows local users to cause a denial of service (memory corruption and system…
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 3 / 5
- KEV catalog (CISA)12 May 2023
- Exploited in EUVD (ENISA)12 May 2023
- Used by ransomwareno
- EPSS above 10 %20.3%
- No account, over the networkno
What to do
Fix
Update to a fixed version: 3.14.4-1
CISA guidance: The impacted product is end-of-life and should be disconnected if still in use.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Description ENISA EUVD
The n_tty_write function in drivers/tty/n_tty.c in the Linux kernel through 3.14.3 does not properly manage tty driver access in the "LECHO & !OPOST" case, which allows local users to cause a denial of service (memory corruption and system crash) or gain privileges by triggering a race condition involving read and write operations with long strings.
Affected products
Open source packages OSV
- linuxDebian:12 · CVE-2014-0196fixed in 3.14.4-1
- linuxDebian:13 · CVE-2014-0196fixed in 3.14.4-1
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 22.5%
References
Other exploited vulnerabilities from the same vendor
- CVE-2026-46300Linux Kernel Missing Initialization of a Variable Vulnerability5.4 · Rising fast
- CVE-2026-53266Linux Kernel Out-of-Bounds Write Vulnerability4.7 · Actively exploited
- CVE-2025-39964Linux Kernel Race Condition Vulnerability4.4 · Actively exploited
- CVE-2025-39682Linux Kernel Improper Check for Unusual or Exceptional Conditions Vulnerability5.8 · Actively exploited
- CVE-2026-53362Linux Kernel Unspecified Vulnerability4.3 · Actively exploited
- CVE-2022-0995Linux Kernel Out-of-Bounds Write Vulnerability4.6 · Actively exploited