Linux Kernel Improper Input Validation Vulnerability
The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the v6k and v7 ARM platforms do not validate certain addresses, which allows attackers to read or modify the contents of arbitrary kernel memory locations…
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 3 / 5
- KEV catalog (CISA)15 Sept 2022
- Exploited in EUVD (ENISA)15 Sept 2022
- Used by ransomwareno
- EPSS above 10 %39.7%
- No account, over the networkno
What to do
Fix
Update to a fixed version: 3.6.4-1~experimental.1
CISA guidance: Apply updates per vendor instructions.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Description ENISA EUVD
The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the v6k and v7 ARM platforms do not validate certain addresses, which allows attackers to read or modify the contents of arbitrary kernel memory locations via a crafted application, as exploited in the wild against Android devices in October and November 2013.
Affected products
Open source packages OSV
- linuxDebian:12 · CVE-2013-6282fixed in 3.6.4-1~experimental.1
- linuxDebian:13 · CVE-2013-6282fixed in 3.6.4-1~experimental.1
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 39.7%
References
Other exploited vulnerabilities from the same vendor
- CVE-2026-46300Linux Kernel Missing Initialization of a Variable Vulnerability5.4 · Rising fast
- CVE-2026-53266Linux Kernel Out-of-Bounds Write Vulnerability4.7 · Actively exploited
- CVE-2025-39964Linux Kernel Race Condition Vulnerability4.4 · Actively exploited
- CVE-2025-39682Linux Kernel Improper Check for Unusual or Exceptional Conditions Vulnerability5.8 · Actively exploited
- CVE-2026-53362Linux Kernel Unspecified Vulnerability4.3 · Actively exploited
- CVE-2022-0995Linux Kernel Out-of-Bounds Write Vulnerability4.6 · Actively exploited