OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input…
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 4 / 5
- KEV catalog (CISA)11 Dec 2025
- Exploited in EUVD (ENISA)11 Dec 2025
- Used by ransomwareno
- EPSS above 10 %61.2%
- No account, over the networkyes
What to do
Fix
Apply the vendor’s fix as soon as it is available.
CISA guidance: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Description ENISA EUVD
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.
Affected products
- 2.26.0, < 2.26.2
- < 2.25.6
Open source packages OSV
Affected libraries according to OSV, with fixed versions.
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 61.2%
References
Other exploited vulnerabilities from the same vendor
- CVE-2024-36401OSGeo GeoServer GeoTools Eval Injection Vulnerability9.3 · Background exploitation
- CVE-2022-24816OSGeo GeoServer JAI-EXT Code Injection Vulnerability9.4 · Background exploitation