Vite Vitejs Improper Access Control Vulnerability
Vite is a frontend tooling framework for javascript. Vite exposes content of non-allowed files using ?inline&import or ?raw?import. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config…
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 4 / 5
- KEV catalog (CISA)22 Jan 2026
- Exploited in EUVD (ENISA)22 Jan 2026
- Used by ransomwareno
- EPSS above 10 %74.9%
- No account, over the networkyes
What to do
Fix
Update to a fixed version: 6.2.4 6.1.3 6.0.13 5.4.16 4.5.11
CISA guidance: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Description ENISA EUVD
Vite is a frontend tooling framework for javascript. Vite exposes content of non-allowed files using ?inline&import or ?raw?import. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected. This vulnerability is fixed in 6.2.4, 6.1.3, 6.0.13, 5.4.16, and 4.5.11.
Affected products
- 6.0.0, < 6.0.13
- 6.1.0, < 6.1.3
- 6.2.0, < 6.2.4
- < 4.5.11
- 5.0.0, < 5.4.16
Open source packages OSV
- vitenpm · GHSA-4r4m-qw57-chr8fixed in 6.2.4
- vitenpm · GHSA-4r4m-qw57-chr8fixed in 6.1.3
- vitenpm · GHSA-4r4m-qw57-chr8fixed in 6.0.13
- vitenpm · GHSA-4r4m-qw57-chr8fixed in 5.4.16
- vitenpm · GHSA-4r4m-qw57-chr8fixed in 4.5.11
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 74.9%