Craft CMS Code Injection Vulnerability
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these…
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 4 / 5
- KEV catalog (CISA)02 Jun 2025
- Exploited in EUVD (ENISA)02 Jun 2025
- Used by ransomwareno
- EPSS above 10 %97.5%
- No account, over the networkyes
What to do
Fix
Apply the vendor’s fix as soon as it is available.
CISA guidance: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Description ENISA EUVD
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.
Affected products
- 3.0.0, < 3.9.14
- 5.0.0-RC1, < 5.5.2
- 4.0.0-RC1, < 4.13.2
Open source packages OSV
Affected libraries according to OSV, with fixed versions.
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 97.5%
References
Other exploited vulnerabilities from the same vendor
- CVE-2025-32432Craft CMS Code Injection Vulnerability9.4 · Background exploitation
- CVE-2025-35939Craft CMS External Control of Assumed-Immutable Web Parameter Vulnerability4.6 · Background exploitation
- CVE-2025-23209Craft CMS Code Injection Vulnerability5.7 · Background exploitation