Background exploitation KEV catalog Ransomware No authentication
CVE-2024-51567

CyberPersons CyberPanel Incorrect Default Permissions Vulnerability

upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is…

CheckOps priority index
9.5/10 Patch within 24 h
Severity10.0
Probability8.4
Exploitation5/5

Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.

EPSS · today 84.4% higher than 99.7% of CVEs
CVSS 3.1 10.0 AC:L/AV:N/A:H/C:H/I:H/PR:N/S:C
Exploited for 726 days 07 Nov 2024
CISA due date 28 Nov 2024 for US federal agencies

Exploitation probability EPSS · FIRST

05010025 Sep05 Oct15 Oct24 Oct02 Nov
EPSS probability (%)Percentile among all CVEs

Exploitation signals 5 / 5

  • KEV catalog (CISA)07 Nov 2024
  • Exploited in EUVD (ENISA)07 Nov 2024
  • Used by ransomwareyes
  • EPSS above 10 %84.4%
  • No account, over the networkyes

What to do

Fix

Apply the vendor’s fix as soon as it is available.

CISA guidance: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Meanwhile

Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.

Manufacturers (CRA)

Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained

Description ENISA EUVD

upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.

Affected products

CyberPanel
Weaknesses (CWE)

Open source packages OSV

Affected libraries according to OSV, with fixed versions.

Timeline

  1. Published

  2. Exploitation reported (ENISA)

  3. Added to the KEV catalog

  4. CISA remediation due date

  5. EPSS peak: 86.6%

References

Other exploited vulnerabilities from the same vendor

  • CVE-2024-51378CyberPanel Incorrect Default Permissions Vulnerability
    9.8 · Background exploitation

Are you affected?

CheckOps reads your SBOMs and scans, and alerts you as soon as one of your dependencies is exploited.

Get notified at launch

Sources: CISA KEV · ENISA EUVD · FIRST EPSS · OSV. Public data aggregated by CheckOps, updated automatically. Source texts remain the property of their authors. All exploited vulnerabilities