GNU Bash OS Command Injection Vulnerability
GNU Bash through 4.3 bash43-026 does not properly parse function definitions in the values of environment variables, which allows remote attackers to execute arbitrary commands via a crafted environment, as demonstrated by vectors…
Severity = CVSS. Probability = EPSS (FIRST). Exploitation = public signals: KEV, EUVD, ransomware, EPSS above 10 %, no account required.
Exploitation probability EPSS · FIRST
Exploitation signals 4 / 5
- KEV catalog (CISA)02 Oct 2025
- Exploited in EUVD (ENISA)02 Oct 2025
- Used by ransomwareno
- EPSS above 10 %99.7%
- No account, over the networkyes
What to do
Fix
Update to a fixed version: 4.3-9.2
CISA guidance: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Meanwhile
Take the service off the internet or restrict access to it, watch the logs and look for signs of compromise.
Manufacturers (CRA)
Exploited vulnerability in your product: early warning to ENISA within 24 h, then notification within 72 h (Article 14 of the Cyber Resilience Act). The CRA explained
Description ENISA EUVD
GNU Bash through 4.3 bash43-026 does not properly parse function definitions in the values of environment variables, which allows remote attackers to execute arbitrary commands via a crafted environment, as demonstrated by vectors involving the ForceCommand feature in OpenSSH sshd, the mod_cgi and mod_cgid modules in the Apache HTTP Server, scripts executed by unspecified DHCP clients, and other situations in which setting the environment occurs across a privilege boundary from Bash execution. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-6271, CVE-2014-7169, and CVE-2014-6277.
Affected products
Open source packages OSV
- bashDebian:11 · CVE-2014-6278fixed in 4.3-9.2
- bashDebian:12 · CVE-2014-6278fixed in 4.3-9.2
- bashDebian:13 · CVE-2014-6278fixed in 4.3-9.2
Timeline
-
Published
-
Exploitation reported (ENISA)
-
Added to the KEV catalog
-
CISA remediation due date
-
EPSS peak: 99.7%
References
Other exploited vulnerabilities from the same vendor
- CVE-2026-24061GNU InetUtils Argument Injection Vulnerability9.3 · Background exploitation
- CVE-2023-4911GNU C Library Buffer Overflow Vulnerability6.8 · Background exploitation
- CVE-2014-7169GNU Bourne-Again Shell (Bash) Arbitrary Code Execution Vulnerability9.3 · Background exploitation
- CVE-2014-6271GNU Bourne-Again Shell (Bash) Arbitrary Code Execution Vulnerability9.3 · Background exploitation