BerriAI LiteLLM Command Injection Vulnerability
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST…
Schweregrad = CVSS. Wahrscheinlichkeit = EPSS (FIRST). Ausnutzung = öffentliche Signale: KEV, EUVD, Ransomware, EPSS über 10 %, ohne Konto.
Ausnutzungswahrscheinlichkeit EPSS · FIRST
Ausnutzungssignale 3 / 5
- KEV-Katalog (CISA)08.06.2026
- In der EUVD ausgenutzt (ENISA)08.06.2026
- Von Ransomware genutztnein
- EPSS über 10 %91,4 %
- Ohne Konto, über das Netznein
Was tun
Beheben
Den Patch des Herstellers einspielen, sobald er verfügbar ist.
Vorgabe der CISA: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Bis dahin
Den Dienst vom Internet nehmen oder den Zugriff einschränken, Protokolle überwachen und nach Kompromittierungsspuren suchen.
Hersteller (CRA)
Ausgenutzte Schwachstelle in Ihrem Produkt: Frühwarnung an die ENISA binnen 24 h, dann Meldung binnen 72 h (Artikel 14 des Cyber Resilience Act). Der CRA erklärt
Beschreibung ENISA EUVD
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
Text der Quelle, auf Englisch.
Betroffene Produkte
- 1.74.2, < 1.83.7
Open-Source-Pakete OSV
Betroffene Bibliotheken laut OSV, mit behobenen Versionen.
Zeitverlauf
-
Veröffentlichung
-
Ausnutzung gemeldet (ENISA)
-
Aufnahme in den KEV-Katalog
-
CISA-Frist zur Behebung
-
EPSS-Höchstwert: 92,6 %
Referenzen
Weitere ausgenutzte Schwachstellen desselben Herstellers
- CVE-2026-59822BerriAI LiteLLM Improper Authentication Vulnerability5,3 · Aktiv ausgenutzt
- CVE-2026-42208BerriAI LiteLLM SQL Injection Vulnerability8,8 · Aktiv ausgenutzt